Compiling rubinius c++ VM in Debian lenny

September 20, 2008 at 1:15 pm (c++, linux, ruby) ()

I have a habit to use testing branch of debian. Currently it’s Lenny.

The problem is, gcc package now is version 4.3. The g++ of that version is stricter (being transitioning to C++-0x), emitting errors when compiling rubinius c++ vm. The solution (workaround, actually) is installing the 4.2 versions, then replacing the gcc and g++ symlinks (prvided by gcc and g++ packages, respectively) to point to gcc-4.2 and g++-4.2, respectively. Yes, it’s a hack.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: